Outage on AWS US-West public data plane

Incident Report for Estuary

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 02:25 UTC

Update

This outage has been resolved.

- This only affected connectors on our AWS US-West public data plane (0.5% of tasks)
- There should be no data loss - connectors went down but our core data read/write processes did not - connectors are resuming and catch up
- Unfortunately as part of the recovery the outgoing IPs of this data plane changed, if you are using IP allowlisting and the AWS US-West public data plane you'll need to allowlist the new IPs:
IPv6: 2600:1f14:1e3d:e400::/56
IPv4: 34.213.10.188/32,52.34.175.198/32
Posted Nov 25, 2025 - 02:25 UTC

Investigating

There is currently an outage on the AWS US-West public data plane, with connector tasks not running. We are working to fix this ASAP.
Posted Nov 25, 2025 - 01:02 UTC
This incident affected: Connectors - Databases, Connectors - SaaS, Connectors - Filestores, and Connectors - Destinations.