Systems have been healthy for the last 6 hours, this issue is resolved.
Posted Mar 19, 2025 - 23:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2025 - 17:45 UTC
Identified
We've identified an issue that's affecting many of the tasks running in our public AWS EU data plane. This issue is also preventing stats from being read from that data plane, so it will appear that no tasks running there are making progress (although some are still making progress). We're working on rolling out a fix ASAP. No other data planes are affected.