Reporting delays

Incident Report for Estuary

Resolved

Reporting is caught back up to real-time.
Posted May 20, 2025 - 21:22 UTC

Investigating

Reporting is currently about an hour delayed. This may cause false data movement alerts.
Posted May 20, 2025 - 20:06 UTC
This incident affected: Reporting.