US Public Data Plane Processing Delays

Incident Report for Estuary

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 15:07 UTC

Update

We've traced the root cause of this to an update to Azure cloud storage which prevented some brokers from persisting data. We are releasing an update to handle the change and as soon as that happens, all tasks will resume normal operation.
Posted Jul 15, 2025 - 14:48 UTC

Identified

Some tasks in the US public data plane are behind on processing. This is due to a lot of tasks being recently created which caused a need to add capacity. That is in progress and should be resolved soon.
Posted Jul 15, 2025 - 13:14 UTC
This incident affected: Runtime.