Estuary UI Downtime

Incident Report for Estuary

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:07 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 12, 2025 - 19:57 UTC

Identified

The Estuary UI is currently down due to a widespread GCP outage
Posted Jun 12, 2025 - 18:27 UTC
This incident affected: Management Portal and Dekaf.