Reporting delays

Incident Report for Estuary

Resolved

Stats are back up to date
Posted Jul 15, 2025 - 17:45 UTC

Investigating

We are currently experiencing reporting delays which may cause false alerts
Posted Jul 15, 2025 - 17:43 UTC
This incident affected: Reporting.