Reporting Delays

Incident Report for Estuary

Resolved

Reporting is fully caught up
Posted Jul 30, 2025 - 15:22 UTC

Investigating

Reporting is currently delayed by about one hour which may cause false alerts
Posted Jul 30, 2025 - 13:57 UTC
This incident affected: Reporting.