Reporting delays: AWS EU data plane

Incident Report for Estuary

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 14:07 UTC

Investigating

Reporting in the AWS EU data plane is approximately 5 hours behind and may cause false alerts. We expect the issue to be resolved imminently.
Posted Jul 02, 2025 - 11:16 UTC
This incident affected: Reporting.