Reporting Delays

Incident Report for Estuary

Resolved

This incident is now resolved and reporting data is back up-to-date.
Posted Mar 03, 2026 - 16:54 UTC

Monitoring

We've identified the underlying issue and have implemented a fix. We're monitoring as our statistics catch back up over the last few hours worth of data.
Posted Mar 03, 2026 - 15:30 UTC

Update

We're continuing to investigate this issue and our team is actively working to identify the root cause.
Posted Mar 03, 2026 - 14:00 UTC

Investigating

We're currently investigating an issue affecting reporting and a small number of tasks on the GCP us-central1 public data plane. Platform statistics may be delayed or unavailable at this time.
Posted Mar 03, 2026 - 13:14 UTC
This incident affected: Reporting.