Estuary Dashboard 403 Error

Incident Report for Estuary

Resolved

This incident has been resolved and dashboard access has been restored.
Posted Mar 30, 2026 - 14:37 UTC

Investigating

We're receiving reports of persistent 403 errors when accessing the Estuary dashboard. We're actively investigating and will provide an update soon.
Posted Mar 30, 2026 - 14:32 UTC
This incident affected: Management Portal.