Accidental Alert Emails

Incident Report for Estuary

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 14:44 UTC

Identified

Alert emails received between midnight and 2 AM ET on March 13th. They were sent in error due to an upgrade in our alert system that unintentionally resent historical and currently irrelevant alerts.
Posted Mar 13, 2025 - 12:47 UTC