Estuary UI Downtime

Incident Report for Estuary

Resolved

The underlying Google CloudRun outage has resolved, and all Estuary services are back to normal functioning.
Posted May 20, 2025 - 16:06 UTC

Update

We are continuing to investigate this issue.
Posted May 20, 2025 - 15:21 UTC

Investigating

We are investigating an issue which is causing dashboard downtime. This seems to be caused by our hosting provider having downtime.
Posted May 20, 2025 - 15:20 UTC
This incident affected: Management Portal.